This project has moved and is read-only. For the latest updates, please go here.
1

Closed

Incompatible Database Version accessing 4.0 DB with SqlCeCmd40

description

I am trying to use sqlcecmd40 to perform a simple query against a SqlCe 4.0 database.
When I run the following command:
sqlcecmd40 -d "Data Source=C:\test.sdf" -q "SELECT * FROM FTPLog"
I receive an error similar to
"Incompatible Database Version. If this was a compatible file, run repair. For other cases refer to documentation. [ Db version = 4000000,Requested version = 3505053 ]"
The database can be opened with SQL Server Compact/SQLite Toolbox. That tool says the database ServerVersion is 4.0.8482.1.
Closed Sep 14, 2015 at 12:32 PM by ErikEJ

comments

ErikEJ wrote May 15, 2015 at 8:11 PM

I think I had a build issue, could you try to download again and test - I have juste updated the .exe

rstewart27104 wrote May 15, 2015 at 9:09 PM

The script is now executing. Thank you for the prompt response, support, and great tools.

ErikEJ wrote May 15, 2015 at 9:24 PM

You are welcome. If you use my tools, I would be very greateful for a review here:

https://visualstudiogallery.msdn.microsoft.com/0e313dfd-be80-4afb-b5e9-6e74d369f7a1/view/Reviews

wrote Sep 14, 2015 at 12:32 PM